MySQLニュース

MySQL固有のPHP用ドライバ、mysqlnd-5.0.1-betaがリリースされました。

オリジナル版:http://lists.mysql.com/announce/448

MySQL固有のPHP用ドライバ、mysqlnd-5.0.1-betaのベータ版がリリースされました。
ソフトウェアは
http://dev.mysql.com/downloads/connector/php-mysqlnd
において、ダウンロード可能です。

MySQL固有のPHP用ドライバは、PHP 5およびPHP 6からMySQL Server 4.1あるいはそれ以降のバージョンに接続可能な追加の方法であり、代替的な方法です。このドライバは、MySQLクライアントライブラリであるlibmysqlの代わりとなるものです。今後は、今まで行っていたようにlibmysqlを使用しても、あるいはmysqlndを使用してもext/mysqliを使用できます。MySQL固有のPHP用ドライバは、MySQL Server 4.1あるいはそれ以降のバージョンに接続できます。

以前に述べたように、ext/mysqliからlibmysqlのサポートを外す予定はありません。既存のアプリケーションが壊れる可能性があるからです。

以下は、変更点です。

Changes
------------

The 5.0.1-beta release covers the functionality of the libmysql beside
some functions that are marked as experimental in the ext/mysqli
documentation. The following additions have been implemented since the
release of 5.0.0-alpha:

* Support for Prepared Statements

* Support for Unicode

* Support for PHP 5

* Performance statistics:
   mysqli_get_client_stats(),
   mysqli_get_connection_stats()

MySQLや関連ソリューションに関するお問い合わせ、お見積などがございましたら、ご連絡ください。

お問い合わせ各MySQL保守サービス見積依頼スマートスタイルOSSストア

ページトップへ